Verification is currently underway for the maintenance.
Posted Apr 01, 2025 - 01:50 EDT
Update
Maintenance is proceeding more slowly than expected so we've added an additional 90 minutes to the work window.
Posted Mar 31, 2025 - 23:48 EDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 31, 2025 - 21:00 EDT
Scheduled
KACE Cloud will be undergoing system maintenance starting March 31, 2025 from 9 PM EDT to 12 AM EDT. We will post a notice here when the upgrade starts and when it is completed.
Posted Mar 17, 2025 - 14:18 EDT
This scheduled maintenance affected: KACE Cloud Admin Portal, KACE Cloud Login, KACE Cloud Device Enrollment, KACE Cloud Help Center, KACE Cloud API's (Account API, Apns API, Application API, Command API, Device API, Notification API, Policy API, West Europe, East US), and KACE Cloud Subscriptions (Subscriptions Portal, Subscriptions API).