KACE Cloud - Possible Performance Issues
Incident Report for KACE
Resolved
The team has applied some infrastructure changes to alleviate the congestion. We will continue to monitor this situation and open a new incident if any additional remediations are required.
Posted Aug 13, 2024 - 10:07 EDT
Monitoring
The team continues to monitor this situation. We will leave this open for tracking purposes.
Posted Aug 12, 2024 - 19:53 EDT
Investigating
The East US production environment is experiencing periods of high utilization which is affecting overall performance. The team is continuing to make adjustments to improve this situation. We appreciate your patience and will post updates when the situation has returned to normal.

Please visit https://changelog.kace.com/labels/kace-cloud for updates on environment and product changes.
Posted Aug 12, 2024 - 16:43 EDT
This incident affected: KACE Cloud Admin Portal, KACE Cloud Login, KACE Cloud Device Enrollment and KACE Cloud API's (Application API, Command API, Device API, Policy API, East US).