KACE Cloud - East US - Degraded performance

Incident Report for KACE

Resolved

The performance issue has been resolved.
Posted Mar 06, 2025 - 17:04 EST

Monitoring

A fix has been deployed to production. We are monitoring the results to ensure stable performance.
Posted Mar 06, 2025 - 15:27 EST

Investigating

We are investigating an issue in the East US data center that is causing several services to experience degraded performance.
Posted Mar 06, 2025 - 10:15 EST
This incident affected: KACE Cloud - North America (Web Console, Device Communications).