KACE Cloud - Possible performance issues

Incident Report for KACE

Resolved

We have provisioned additional infrastructure to handle the heavier load on the system. Please open new support cases if you are still experiencing slowdowns. Thank you for your patience as we worked through these issues.
Posted Aug 14, 2024 - 17:27 EDT

Investigating

The East US production environment continues to experience occasional periods of high utilization which is affecting overall performance. The team is continuing to make adjustments to improve this situation. We appreciate your patience and will post updates when the situation has returned to normal.
Posted Aug 13, 2024 - 15:06 EDT
This incident affected: KACE Cloud Admin Portal, KACE Cloud Login, KACE Cloud Device Enrollment and KACE Cloud API's (Application API, Command API, Device API, Notification API, Policy API, East US).