KACE Cloud - West Europe Performance Issue

Incident Report for KACE

Resolved

A code change has been published to the West Europe data center to improve handling of patch detection data.
Posted Feb 17, 2025 - 12:33 EST

Investigating

The regional instance of KACE Cloud running in West Europe is experiencing a degradation in performance related to patching. The issues is under investigation. We will update this once the root cause has been identified and a solution has been published.
Posted Feb 12, 2025 - 21:35 EST
This incident affected: KACE Cloud - Europe (Web Console).